'Approved Sites' lost during Crowd upgrade
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
Upon upgrading Crowd, users that used to be automatically approved are presented with the following:

Diagnosis
This will only affect instances that use the HSQL database for CrowdID (even if you're using another database for Crowd itself). To confirm if you are using the an HSQL database, look for a database/
directory in your installation directory.
Cause
When upgrading Crowd, you download a new installation directory and point it at your old home directory. Unfortunately, the OpenID Server's database is stored in the installation directory, so it needs to be manually copied across otherwise all of the CrowdID server's data is lost.
Solution
Resolution
Copy the database/
directory from your old installation folder to your new one. This will allow your CrowdID server to find the missing data.
Having done so, please migrate your CrowdID data to a production database to resolve this problem permanently.
To do so, you'll need to first connect CrowdID to a production database.
Next, migrate from HSQLDB to MySQL, or any other production database of your choosing. (Note: although this guide is for Confluence, it will also work with CrowdID's HSQL database).
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