XML import for a space got stuck on "Applying special processing" phase

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

During an XML space import, the UI could get stuck on the "Applying special processing" phase for a long time with a 100% completion ratio.

Diagnosis

The below screen could be visible on the import space page:

(Auto-migrated image: description temporarily unavailable)

Cause

After some time if the screen doesn't change the import could be completed but somehow doesn't change the import screen. It can be verified by opening a new window and checking the Confluence for the recently imported space. If it's imported successfully and there is no issue you may ignore the import screen. If errors or missing contents are noticed there might be some other problems please generate a Support Zip and raise a ticket to the support team for further investigation.

Updated on April 11, 2025

Still need help?

The Atlassian Community is here for you.