XML Import failure due to "Your request could not be processed because a required security token was not present in the request."

Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

While attempting to load a large XML backup via the web client the following error appears after some time and fails the import process.

The error displayed is:

"Your request could not be processed because a required security token was not present in the request. You may need to re-submit the form or reload the page."

Cause

If using the select and upload method for large files, it can cause the web browser to timeout before the upload is complete.

Resolution

  1. Put the backup file within <confluence_home>/restore on the Confluence server. (Create manually if the directory does not exist.)

  2. In Confluence, open the General Configuration and choose Backup and Restore under the Administration section

  3. Select the backup file under the section Restore a backup from the Confluence Home Directory

  4. Start the restore

Updated on April 21, 2026

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