Viewing a page causes "Unable to resolve owner of loading collection" error message in Confluence

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Viewing a page shows the following error in logs.

1 2 3 4 5 6 7 2020-05-04 23:07:05,044 ERROR [http-nio-8080-exec-13] [atlassian.confluence.servlet.ConfluenceServletDispatcher] sendError Could not execute action -- url: /pages/viewpage.action | traceId: 1273a70858101de8 | userName: admin | referer: http://localhost:8090/login.action?os_destination=%2Fpages%2Fviewpage.action%3BRelease%2BNote%2BCreation%2BStandards%2Band%2BGuidelines&permissionViolation=true java.lang.RuntimeException: Error rendering template for decorator root at com.atlassian.confluence.setup.velocity.ApplyDecoratorDirective.render(ApplyDecoratorDirective.java:162) . Caused by: org.hibernate.HibernateException: Unable to resolve owner of loading collection [[com.atlassian.confluence.core.ContentEntityObject.contentProperties#152548091]] for second level caching at org.hibernate.engine.loading.internal.CollectionLoadContext.addCollectionToCache(CollectionLoadContext.java:321)

In some cases the error can happen on some other actions in Confluence as well. Though, as long as the cause of the error is the same we can proceed with the resolution here.

Cause

A couple of causes have been identified for this issue:

  • Confluence is unable to load a data element from the cache. In the example above, this would correspond to contentProperties table for the ContentID column where ID 152548091 that's noted in the logs.

  • Another possible cause is a conflict with a third party plugin.

Solution

To address the first possible cause, try clearing Confluence's cache which should force a refresh of the page:

  • Log into the admin console > General Configuration > Cache Management

  • Select Flush all at the bottom of the page

To verify whether this is plug-in relate, temporarily enable safe mode during a maintenance window or down time and seeing if the page renders. If the page does render, then reenable the third party plugins one by one and retest the page each time to see which plugin causes the page to not display as expected.

If neither of these steps help, then another option would be to rebuild the indexes of the system using steps provided in Content Index Administration.

Updated on April 11, 2025

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