Using Confluence Blueprints error out with "We can't create that blueprint right now. Failed to add entry to the queue"
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Using Confluence blueprints may error out with "We can't create that blueprint right now. Failed to add entry to the queue"
Environment
This problem was identified in Confluence server and Data Center version 7.2.1. It could also affect later versions of Confluence
Diagnosis
The following is found in atlassian-confluence.log:
1
2
3
4
2021-01-04 11:09:08,640 ERROR [http-nio-8090-exec-13] [core.persistence.hibernate.HibernateObjectDao] reIndex Unable to reIndex object: page: test (38207903) -- Failed to add entry to queue
-- referer: https://localhost/admin/systeminfo.action | url: /rest/create-dialog/1.0/content-blueprint/create-draft | traceId: 2103ac1297a1ade0 | userName: admin
com.atlassian.confluence.api.service.exceptions.ServiceException: Failed to add entry to queue
at com.atlassian.confluence.impl.journal.DefaultJournalService.enqueue(DefaultJournalService.java:33)
Cause
Corrupt index and 'main_index' file. This could happen due to a system/server outage.
Solution
When an index is corrupted, we need to Rebuild the Content Indexes From Scratch.
Was this helpful?