Users is not longer able to access previously subscribed Team Calendars

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Users who were subscribed to a team calendar were able to view the calendar without any problems.

In the atlassian-confluence.log file you can observer NullPointerException as the one below:

1 2 3 4 5 6 7 8 2015-10-09 09:28:27,112 ERROR [http-nio-8090-exec-4] [common.error.jersey.ThrowableExceptionMapper] toResponse Uncaught exception thrown by REST service: null -- referer: http://localhost:8090/confluence/calendar/mycalendar.action | url: /confluence/rest/calendar-services/1.0/calendar/events.json | userName: testa java.lang.NullPointerException at com.atlassian.confluence.extra.calendar3.calendarstore.DelegatingCalendarDataStore.getEventEditUserRestrictions(DelegatingCalendarDataStore.java:392) at com.atlassian.confluence.extra.calendar3.DefaultCalendarPermissionManager.getEventEditUserRestrictions(DefaultCalendarPermissionManager.java:65) at sun.reflect.GeneratedMethodAccessor1224.invoke(Unknown Source) ... ...

Cause

Space Permissions or Calendar Restrictions have changed.

Resolution

Review and fix the space permission of the affected calendar, and check that no new restrictions have been applied to the calendar. If they have changed, you will need to revert the change.

Updated on April 8, 2025

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