Users are unable to perform various functions after migrating Confluence to a new server

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

After migrating Confluence to a new server, users are unable to perform various funtions:

  • Cannot share pages

  • Cannot move pages

  • The comment panel doesn't expand

  • Cannot drag attachments on to pages in edit mode

No errors appear in any Confluence log file.

Diagnosis

Diagnostic Steps

  • Check the network requests being made and look for failed requests for batch.js

  • Try to replicate the behavior in a private browser sessions

Cause

There is a mismatch between the cached JavaScript from the old server stored in the user browsers and the new Confluence server. While they are able to authenticate with Confluence, it fails to properly load JavaScript.

Solution

Resolution

  1. Clear the browser's cache

    • In Chrome:

      1. Click the menu (three dots) in the top right of the browser

      2. Click More Tools > Clear Browsing Data

      3. Ensure that Cached images and files is checked (the others can be left unchecked)

      4. Set the time range to All Time

      5. Click Clear Data

    • In Firefox:

      1. Click the menu button (three lines)

      2. Click Preferences

      3. Click Privacy & Security > Clear Data

      4. Ensure that Cached Web Content is checked (the others can be left unchecked)

      5. Click Clear

    • In Safari:

      • Open the preferences dialog by using CMD+, or from the top menu Safari > Preferences

      • Click Privacy

      • Click Manage Website Data

      • Search for the domain name used to serve Confluence

      • Select the appropriate site

      • Click Remove

    • In IE11:

      1. Click the Tools button (cog)

      2. Select Safety > Delete browsing history

      3. Ensure that Cached images temporary Internet files is checked (the others can be left unchecked)

      4. Click Delete

    • In Edge:

      • Click the Hub button (three lines)

      • Click History (clock) > Clear History > Show more

      • Ensure Cached data and files is checked (the others can be left unchecked)

      • Click Clear

Updated on April 7, 2025

Still need help?

The Atlassian Community is here for you.