User Picker Fails to Open with 404 or 'Page Not Available' Error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When clicking the icons which open the user picker, the pop-up window fails to open as a 404 or 'page not found' error. In the following example, we show the user picker failing in the task list macro.

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Cause

  1. The URL we are using to connect to Confluence with does not match the baseURL.

  2. There is a reverse proxy which is incorrectly set or other another network related issue.

Resolution

Cause 1

 Set the Base URL to match the URL you are using to connect to Confluence. For more details please see Configuring the Server Base URL.

Cause 2

Double check the settings for the proxy in use, as there are many types of proxies it is hard to give a specific instructions. A good diagnostic step would be to run a trace to see where the redirection is failing.

Updated on April 8, 2025

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