User Cannot Change Profile

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

A particular user cannot make any changes to their profile. When on the "Profile" page, the entire menu on the left (Labels, Watches, Drafts, Settings) is missing. The user belongs to the same groups as others, that work just fine.

Cause

The user account was created using Confluence's remote API. Hence usual checks for valid usernames effective when adding the user via the UI, were not applicable. Hence this user was created with an additional whitespace (blank) at the end. The logs indicated the URL as:

http://<Base URL>/admin/users/viewuser.action?username=<Useranme>%2B

Instead of the expected:

http://<Base URL>/admin/users/viewuser.action?username=<Username>

Resolution

Rename the username to remove the whitespace.

Updated on April 8, 2025

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