Usage Tracking Plugin and Mail Page Plugin Become Disabled Mysteriously

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Bundled plugins, like the Usage Tracking or Mail Page plugin, become disabled mysteriously. Logs contain messages like:

2010-05-17 19:19:13,618 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] updatePlugin Updating plugin 'com.atlassian.confluence.ext.usage:0.12' to 'com.atlassian.confluence.ext.usage:0.13' 2010-05-17 19:19:13,619 INFO [main] [atlassian.plugin.manager.DefaultPluginManager] notifyPluginDisabled Disabling com.atlassian.confluence.ext.usage

Cause

A Confluence administrator has updated the plugin to a version which is listed as compatible, but which proves to be incompatible.

There is no need to upgrade bundled plugins. See CONFSERVER-19699 - Prevent bundled plugins from being upgraded for the improvement request.

Resolution

  1. Uninstall the plugin from the Administration console.

  2. Restart Confluence. This will reload the plugin.

Updated on May 22, 2025

Still need help?

The Atlassian Community is here for you.