UPM fails to load with message "Illegal character in path at index"
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When trying to load the UPM, it fails with the following message:
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Illegal character in path at index ...
The UPM doesn't not load and you are unable to install/update or remove plugins from the UI.
Environment
Confluence 6.15.4 but it might occur on newer Confluence and UPM versions
Diagnosis
The following message appears in the Confluence logs:
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ERROR [http-nio-8090-exec-22] [common.error.jersey.ThrowableExceptionMapper] toResponse Uncaught exception thrown by REST service: Illegal character in path at index 1: ${project.organization.url}
-- referer: https://BASE_URL/confluence/plugins/servlet/upm/marketplace/search?q=smart%20t | url: /confluence/rest/plugins/1.0/available/com.mute.confluence.plugins.xTables-key | traceId: c94153b5ac08c6ae | userName: xxxxxx
java.lang.IllegalArgumentException: Illegal character in path at index 1: ${project.organization.url}
at java.net.URI.create(Unknown Source)
at com.atlassian.upm.rest.representations.UpmLinkBuilder.addPluginLicenseLinks(UpmLinkBuilder.java:502)
at com.atlassian.upm.rest.representations.UpmLinkBuilder.buildLinksForAvailablePlugin(UpmLinkBuilder.java:374)
at
Cause
As seen in the stack trace, the error above is caused by a third party plugin called Smart tables from the vendor TECHUP but it could also be caused by other malfunctioning plugins. It's recommended to confirm the offending plugin within the stack trace as the above example.
Solution
Follow the steps from this KB article to remove the malfunctioning add on and contact the plugin vendor for the plugin fix/correction:
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