Universal Plugin Manager is malfunctioning due to "Entry type not found for upm.auditLog.upgrade.plugin.failure"

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

UPM is malfunctioning with the following error in the UI:

Entry type not found for upm.auditLog.upgrade.plugin.failure

Diagnosis

The following appears in the atlassian-confluence.log:

java.lang.IllegalArgumentException: Entry type not found for upm.auditLog.upgrade.plugin.failure

Cause

  • It's a bug affecting UPM 2.0, the issue is resolved in UPM 2.0.3 and higher.

  • The audit logging of UPM becomes corrupted

Solution

Upgrade your UPM to version 2.0.3 or higher.

Workaround

  1. Backup Confluence database.

  2. Remove UPM audit logging manually by running the following SQL query against Confluence database:

    UPDATE BANDANA SET BANDANAVALUE = '<list/>' WHERE BANDANAKEY IN ('com.atlassian.upm.log.PluginSettingsAuditLogService:log:upm_audit_log_v3','com.atlassian.upm.log.PluginSettingsAuditLogService:log:upm_audit_log');
  3. Restart Confluence

Updated on June 11, 2025

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