Universal Plugin Manager is Broken Due to Database Inconsistency

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Most Universal Plugin Manager features such as upgrade checking and future compatibility test. are unusable The following line appears on top of the page,

1 Error encountered while retrieving saved configuration

as describe on this screenshot

(Auto-migrated image: description temporarily unavailable)

Diagnosis

Execute this SQL query and see if it return a result

1 SELECT * FROM BANDANA WHERE BANDANAKEY = 'com.atlassian.upm.ConfigurationStore:configuration:upm_configuration';

Resolution

If the above SQL query return any result, please proceed with the following steps

  1. Create a database dump as a safety precaution

  2. Execute the following SQL query:

    1 DELETE FROM BANDANA WHERE BANDANAKEY = 'com.atlassian.upm.ConfigurationStore:configuration:upm_configuration';
  3. Access "Cache and Statistics" menu under your administration page

  4. Click "Flush All"

  5. See if the issue persist

  6. If the issue persist, please shutdown and refresh plugin cache

Updated on April 8, 2025

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