Universal Plugin Manager Inaccessible or Does Not Show Any Plugins

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

  1. You cannot access the Universal Plugin Manager from the administration panel.

  2. You may receive an error:

    1 An unexpected error has occurred. Please refer to the logs for more details.

OR

  1. You can reach the Universal Plugin Manager, but none of your installed plugins appear under the "Manage Existing" tab. System plugins also fail to appear when clicking "Show System Plugins".

  2. You see this warning message:

    1 2 The base URL configuration of your instance is inconsistent with the URL in your browser. This may prevent many  operations on this page from working correctly. See the UPM documentation for more details about this error.

Cause

There are a few potential causes:

  1. The most common problem is that your server base URL does not match the actual URL of the site.

  2. Incorrect or missing proxy settings in your server.xml when accessing Confluence behind a proxy.

  3. Incorrect plugin loading order causing UPM to fail to initialize properly when Confluence is started.

  4. It is possible that if you have Reverse Proxy's timeout set to a short timeframe and the UPM would need longer than the set limit in order to be fully loaded

Workaround

In Confluence 5.10 and earlier, you can use the old plugin administration panel at:

http://<server base url>/admin/viewplugins.action

Resolution

In matching order for the above listed causes:

  1. Your server base URL needs to match the URL that you are using to access Confluence. To change this setting, go to Admin >> General Configuration.

  2. Your <confluence-install>/conf/server.xml must contain your proxy information in the Connector element:

    1 2 3 4 5 <Connector proxyName="www.yourdomain.com" proxyPort="80" className="org.apache.coyote.tomcat4.CoyoteConnector"  port="8090" minProcessors="5" maxProcessors="75" enableLookups="false" redirectPort="8443" acceptCount="10" debug="0" connectionTimeout="20000" useURIValidationHack="false" URIEncoding="UTF-8"/>
  3. Check for any disabled system plugins. If you are not able to access the Plugin manager at all, use the workaround above to access the legacy plugin list. While it does not label system plugins like the Plugin Manager, you can still use it to enable any Atlassian plugins for testing. It is also recommended that you flush your plugin cache before restarting your instance by deleting the following directories:

    • <confluence-home>/plugin-cache

    • <confluence-home>/plugins-osgi-cache

    • <confluence-home>/plugins-temp

    • <confluence-home>/bundled-plugins

    • <confluence-home>/bundled-plugins_language

Updated on April 8, 2025

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