UnexpectedRollbackException due to corrupted space layout

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After Customizing a space's layout, the following symptoms are produced:

  1. "Space Admin" is inaccessible, and the error below is generated.

  2. Other content remains accessible without issue, such as the space homepage and child pages.

    1 2 3 4 Cause: org.springframework.transaction.UnexpectedRollbackException: Transaction rolled back because it has been marked as  rollback-only at org.springframework.transaction.support.AbstractPlatformTransactionManager.commit (AbstractPlatformTransactionManager.java:626)

Cause

The root cause is corrupted content within the layout.

Resolution

Revert the customized layout to the default layout as shown below. After reversion, you will be able to customize your layout again. To revert the layout to the default, use the following URL pattern:

1 <yourDomainURL>/spaces/resetdecorator.action?decoratorName=decorators/space.vmd&key=<spaceKEY>
Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.