Unable to Upload / Update a Plugin in the Universal Plugin Manager

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

User is having trouble uploading a plugin via the Universal Plugin Manager . There is a dialog box than hangs displaying the text "Uploading Plugin XXXX" with a loading gif that does not seem to make any progress.

The following appears in the atlassian-confluence.log:

1 2 3 com.sun.jersey.server.impl.application.WebApplicationImpl onException SEVERE: Internal server error java.lang.RuntimeException: org.apache.commons.fileupload.FileUploadBase$IOFileUploadException: Processing of multipart/form-data request failed. Read timed out

Cause

Communication to the server that is hosting Confluence does not allow uploads from a remote machine. This is especially a limiting factor if Confluence is configured not to allow the Universal Plugin Manager to connect to the Atlassian Marketplace

Resolution

  • Log into a web browser on the machine that is hosting Confluence

  • Upload the plugin from the host machine

Updated on April 8, 2025

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