Unable to Upgrade or Save Pages Due to Table is Full Error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When Confluence initiates the upgrade process, errors occur and the following appears in the atlassian-confluence.log. These errors may also appear when trying to save a page:

1 2 3 4 5 6 ERROR [main] [hibernate.tool.hbm2ddl.SchemaUpdate] execute The table '#sql-73a5_5' is full ERROR [main] [hibernate.tool.hbm2ddl.SchemaUpdate] execute could not complete schema update java.sql.SQLException: The table '#sql-73a5_5' is full at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1072) at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3563) ...

Cause

MySQL can't alter the table since it specifies a certain amount of space for each table and has reached its maximum size. It usually occurs in Innodb storage format, where it's configured in my.cnf or my.ini.

Resolution

  1. Stop MySQL

  2. Backup my.cnf file

  3. Remove the particular line if it's inside the file

    1 innodb_file_per_table
  4. Replace the previous line with the following, if the previous configuration did not exist put the following line under [mysqld]

    1 innodb_data_file_path = ibdata1:10M:autoextend
  5. Restart MySQL

Updated on April 15, 2025

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