Unable to update the Universal Plugin Manager (UPM)

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

When trying to upgrade the Universal Plugin Manager (UPM), the installation hangs (more than 5 to 10 minutes) as seen here:

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The following appears in the atlassian-confluence.log:

1 2 3 4 5 6 7 2014-10-23 10:38:32,406 INFO [pool-17-thread-1] [atlassian.plugin.manager.DefaultPluginManager] updatePlugin Updating plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' from version '2.17.5' to version '2.18' 2014-10-23 10:38:32,408 INFO [pool-17-thread-1] [atlassian.plugin.manager.DefaultPluginManager] notifyPluginDisabled Disabling com.atlassian.upm.atlassian-universal-plugin-manager-plugin 2014-10-23 10:38:33,984 WARN [pool-17-thread-1] [plugins.createcontent.extensions.BlueprintModuleDescriptor] init i18n-name-key is a required attribute of <blueprint> for module: com.gliffy.integration.confluence:gliffy-blueprint -- referer: https://avwikitestupgrade.xxxxx.com:8443/plugins/servlet/upm | url: /rest/plugins/self-update/1.0/ | userName: xxxx 2014-10-23 10:39:34,100 INFO [pool-17-thread-1] [atlassian.plugin.manager.DefaultPluginManager] notifyPluginDisabled Disabling com.atlassian.confluence.extra.team-calendars 2014-10-23 10:40:37,887 ERROR [http-bio-8443-exec-25] [confluence.status.service.DefaultSystemInformationService] getModifications -- referer: https://avwikitestupgrade.xxxxx.com:8443/plugins/servlet/stp/view/ | url: /plugins/servlet/stp/view/detect-issues/view | userName: xxxx

Diagnosis

Disable all plugins manually (do not enable safe mode) and try to update the UPM.

Cause

There is a plugin that is causing conflict that, in turn, causes the install to hang.

Solution

Workaround

Disable all plugins and run the UPM.

Resolution

To find the offending plugin, please use the following steps after you have confirmed the update works when disabling plugins.

  1. Stop the Confluence service

  2. Run this query on your database:

    1 select plugindataid,pluginkey,filename,lastmoddate from plugindata;
  3. Please make note of what plugindataid is associated with the com.atlassian.upm.atlassian-universal-plugin-manager-plugin

  4. Then run:

    1 delete from plugindata where plugindataid = <pluginid from upm>;

    changing <pluginid from upm> to the number you found in step 3

  5. Delete the following folders

    • <confluence-home>/bundled-plugins

    • <confluence-home>/plugins-cache

    • <confluence-home>/plugins-osgi-cache

    • <confluence-home>/plugins-temp

    • <confluence-home>/bundled-plugins_language

  6. With all of the plugins disabled, re-enable each plugin one-at-a-time and try to update the UPM

  7. Once the offending plugin is found, either remove or update the plugin

Updated on April 8, 2025

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