Unable to Update Team Calendars for Confluence After Confluence Upgrade

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

After upgrading Confluence, Team Calendars for Confluence needs to be updated from version 4.x.x to version 5.x.x. However, the update process takes very long time and never finish.

The following appears in the atlassian-confluence.log:

1 2 2015-01-15 05:30:28,454 WARN [UpmAsynchronousTaskManager:thread-3] [confluence.util.profiling.DurationThresholdWarningTimingHelperFactory] logMessage Execution time for publishing event com.atlassian.confluence.event.events.plugin.PluginInstallEvent(com.atlassian.confluence.extra.team-calendars) took 47192339 ms (warning threshold is 5000 ms) – url: /wikisneu/rest/plugins/1.0/ | referer: https://wiki.site.com/confluence/plugins/servlet/upm | userName: tester

Diagnosis

  • Ensure that the database is configured according to Database Configuration documentation

  • Enable Team Calendars for Confluence debugging (log4j.logger.com.atlassian.confluence.extra.calendar3.upgrade.task=DEBUG) and the following entries are shown:

    1 2 3 2015-01-26 12:34:54,063 INFO [active-objects-init-system tenant-0] [calendar3.upgrade.task.CalendarContentTypeReindexingUpgradeTask] upgrade ====================End Upgrade Task for reindexing Custom Content Type Team Calendars for Confluence============================== 2015-01-26 12:34:55,508 INFO [active-objects-init-system tenant-0] [calendar3.upgrade.task.CalendarContentTypePermissionSyncUpgradeTask] upgrade ====================Start Upgrade Task To Sync Calendar Permissions with Calendar Content Type============================== 2015-01-26 12:34:55,972 INFO [active-objects-init-system tenant-0] [calendar3.upgrade.task.CalendarContentTypePermissionSyncUpgradeTask] upgrade ====================End Upgrade Task To Sync Calendar Permissions with Calendar Content Type==============================

    ... however it still ends up with the WARN message shown in the Symptoms section.

Cause

The exact cause hasn't been found yet. This could be caused by incompatibility between older UPM and Team Calendars for Confluence 5.x.x.

Solution

Resolution

  1. Right after Confluence upgrade process, update UPM to the latest version

  2. Update Team Calendars for Confluence

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.