Unable to update license key in Confluence with the error message "The license you entered was not valid"
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
While updating a Confluence license, for example:
From Evaluation to a newly purchased license
From Commercial to a Developer license
etc
Upon clicking "save", the newly entered license is not updated with the error message "The license you entered was not valid" and the details of the license still belong to the old license.
Please see the following screenshot where the problem arises after entering a newly purchased commercial license from an existing evaluation license:

Diagnosis
Upon clicking Save, Confluence should automatically update itself to use the newly entered license.
Cause
This problem is caused by corrupted cache in Confluence.
Solution
Resolution
Clear Confluence plugin cache. See the following documentation for reference:
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