Unable to update Confluence Data Center app

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When managing apps in your Confluence instance, you see the message "This add-on is not compatible with your Confluence instance. Request an update from the vendor." However, you're unable to update the app via Manage apps.

Environment

Confluence 9.x (may affect other versions)

Diagnosis

You can't update an app via the Manage apps, even if the app states "This add-on is not compatible with your Confluence instance. Request an update from the vendor." There is no option to update the app.

Checking the Atlassian Marketplace, you can confirm there is a newer version of the app available.

Cause

Apps can only be updated to a higher version that was released after the version you have installed

This can occur if the vendor provides different app versions for each version of Confluence, and the highest version of the app was released before the current version you have installed.

For example, the vendor releases versions 2.x.x for Confluence 8.x, and 3.x.x for Confluence 9.x. If version 3.0.2 (the highest one, for Confluence 9) is released before version 2.7.1 (for Confluence 8), it won't be possible to update this app via the UI. Here's a more detailed example:

  1. The vendor releases version 2.7.1 (for Confluence 8) in March, after having released 3.0.2 (for Confluence 9) in January.

  2. A Confluence admin updated the app to 2.7.1 in Confluence 8.x, and then upgraded Confluence to 9.x.

  3. The app version currently installed in the instance is in version 2.7.1, but it can't be upgraded because version 3.0.2 was released before 2.7.1.

You can only upgrade apps that are compatible with your current Confluence version and were released after the version you have installed.

Solution

If this issue happens in a test environment, you can consider uninstalling the app and reinstalling it in the latest version.

However, if this happens in your production environment, a safer approach is to wait for the next version of the app that is compatible with your Confluence version.

Updated on May 22, 2025

Still need help?

The Atlassian Community is here for you.