Unable to Start Windows Service with Tomcat 7

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

The Confluence Windows Service installation is successful:

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But the startup fails with this:

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There are no commons-daemon log generated in ConfluenceInstallation/logs (this is normally the logs used to identify the service-related error.

Diagnosis

Cause

The windows service is not installed with the correct user permissions (need to install it with the Administrator privilege). This is due to the fact that tomcat7w.exe is still run as a regular user during service.bat install Confluence.

Solution

Resolution

  • Right click on tomcat7w.exe, (located in ConfluenceInstallation/bin), and hit Properties. Navigate to the Compatibility tab, and select Run this program as an administrator

  • Apply the changes

  • Run Command Prompt as an Administrator. To do this, look for "cmd" in your computer, right click on it, and hit Run as Administrator.

  • cd to ConfluenceInstallation/bin , and run:

    1 service.bat install confluence
Updated on April 2, 2025

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