Unable to start Confluence Windows service after allocating JVM memory

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

In the "Event Properties" window, it shows:

1 The Apache Tomcat service terminated with service-specific error 0(0x0)

The jakarta-service.log contains:

1 2 3 410 javajni.c error CreateJavaVM Failed 953 prunsrv.c error Failed initializing java C:\<the_confluence_installed_directory>\bin\bootstrap.jar 1202 prunsrv.c error ServiceStart returned 2

Cause

The JVM memory (-Xmx or -xx:MaxPermsize) is set too high or to an invalid value.

Here are some discussions:

Resolution

Reducing the maximum heap space or Perm Gen size fixed the problem. This article describes the procedure for changing the memory parameters:

Fix java.lang.OutOfMemoryError in Confluence

Updated on April 8, 2025

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