Unable to Sign Up or Add a New User

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Adding a new user to Confluence returns a stack trace:

com.atlassian.core.exception.InfrastructureException: com.atlassian.user.EntityException: Was unable to create user [zedyap]  but the credentials provider [bucket.user.providers.CachingCredentialsProvider@10e7264] did not say why.

Also, public sign up fails due to this error.

Cause

Confluence user management is delegated to JIRA logins. Confluence has read-only access to JIRA database, hence, the user addition fails.

There is a request at CONFSERVER-11917 - Improve error message which appears when trying to add a user while JIRA user management is enabled to fix the misleading error message.

Resolution

Add the new user in JIRA instead. To avoid the misleading error message:

Updated on May 22, 2025

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