Unable to see bundled macro after upgrade

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After upgrading Confluence users are not able to see macro in the macro browser , eg: The Roadmap planner macro

The following appears in the atlassian-confluence.log

1 2 3 4 5 6 7 8 2015-06-03 19:11:48,840 ERROR [localhost-startStop-1] [plugin.osgi.util.OsgiHeaderUtil] getManifest Cannot get manifest resource from plugin artifact 'confluence-roadmap-plugin-12.3.2_1433309154000.jar': Cannot open JAR file: /var/atlassian/application-data/confluence/plugins-osgi-cache/transformed-plugins/confluence-roadmap-plugin-12.3.2_1433309154000.jar 2015-06-03 19:11:48,917 ERROR [localhost-startStop-1] [atlassian.plugin.loaders.ScanningPluginLoader] deployPluginFromUnit Unable to deploy plugin 'com.atlassian.confluence.plugins.confluence-roadmap-plugin' from 'Unit: /opt/atlassian/confluence/confluence/WEB-INF/atlassian-bundled-plugins/confluence-roadmap-plugin-12.3.2.jar (1433309154000)'. 2015-06-03 19:11:48,935 ERROR [localhost-startStop-1] [atlassian.plugin.loaders.ScanningPluginLoader] deployPluginFromUnit Because of the following exception: java.lang.IllegalArgumentException: File must be a jar: /var/atlassian/application-data/confluence/plugins-osgi-cache/transformed-plugins/confluence-roadmap-plugin-12.3.2_1433309154000.jar at com.atlassian.plugin.osgi.factory.transform.JarUtils.withJar(JarUtils.java:103) at com.atlassian.plugin.osgi.factory.transform.JarUtils.getManifest(JarUtils.java:38) ... Caused by: java.util.zip.ZipException: error in opening zip file

Cause

The plugin cache is corrupted.

Resolution

  1. Shutdown Confluence

  2. Ensure the user running Confluence has full read/write privileges to the confluence-home directory.

  3. Remove the following directories

    This will remove the plugin cache files only and will not permanently remove any plugins. These directories will be recreated during the next Confluence startup.  However, some third-party plugins may store metadata in these directories, so we recommend creating a temporary backup of the directories.

    • <confluence-home>/bundled-plugins

    • <confluence-home>/plugins-cache

    • <confluence-home>/plugins-osgi-cache

    • <confluence-home>/plugins-temp

    • <confluence-home>/bundled-plugins_language

  4. Start Confluence

Updated on April 16, 2025

Still need help?

The Atlassian Community is here for you.