Unable to search/add user in Team Calendars for Confluence
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
User could not be added in the who field as it is not recognized as a valid user and the User suggestion in the Team Calendars for Confluence "who" field could not find the user.

Cause
The user has not been added into the indexes yet. It is also possible that the indexes has been corrupted.
Resolution
Manually rebuild the index, as described in Content Index Administration
If the above doesn't work, Rebuild the indexes from scratch
If the issue persist after rebuilding the indexes from scratch, please follow the Confluence Indexing Troubleshooting Guide
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