Unable to save new license with 'The license you entered is not a valid cluster license' error due to removed files from installation directory

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When saving a new license key with a higher or lower user tier, the error 'The license you entered is not a valid cluster license' is shown. However, the instance is not deployed in a clustered environment.

The following appears in the atlassian-confluence.log:

1 2 2014-01-29 23:55:09,227 WARN [TP-Processor9] [atlassian.plugin.webresource.DefaultResourceDependencyResolver] resolveDependencies Cannot find web resource module for: com.atlassian.analytics.analytics-client:js-events -- url: /plugins/servlet/notifications-miniview | userName: admin | referer: https://localhost:8090/admin/doupdatelicense.action

Cause

Some required files were removed from the Confluence Installation Directory.

Resolution

  • Restore any of the missing files (from the following) to the installation directory:

    • META-INF/maven/com.atlassian.confluence/confluence-webapp/pom.properties

    • WEB-INF/lib/xwork-1.0.3.4.jar

    • META-INF/maven/com.atlassian.confluence/confluence-webapp/pom.xml

    • WEB-INF/lib/confluence-cache-ehcache-4.3.7.jar

Updated on April 8, 2025

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