Unable to save Inline comment in IE

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

The following appears in the page when you try to save the comment

(Auto-migrated image: description temporarily unavailable)

Diagnosis

  1. Go to the page that having this issue.

  2. Click on the bullet beside the share

  3. Then click on View storage format, after that find for the following:

    1  
  4. If you have that HTML encode it mean you are affected by this issue.

Cause

The root cause of the issue is that in IE, it failed to pare the space HTML encode "  " to a normal space which failed the check in our highlight action plugin as it is consider as a macro

Solution

Workaround

  1. Install Source editor

  2. Navigate to the page that have this issue.

  3. Click edit and then open the source editor "<>"

  4. Find for the following HTML encode and remove it:

    1 &nbsp
  5. Save the page after you completely remove the html encode.

Updated on April 8, 2025

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