Unable to Retrieve Attachment or Insert Into a Page

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

Attachment can't be retrieved or inserted into a page. The following warning message appears on the page:

(Auto-migrated image: description temporarily unavailable)

Diagnosis

This issue is not affected by a custom layout or velocity changes as per the following KBs:

Cause

Reverse proxy is configured with http compression (gzip).

Solution

Resolution

Remove/disable gzip completely.

Updated on April 2, 2025

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