Unable to restore Demo Space

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When trying to restore the Demo Space by uploading the demo-site.zip in <Confluence Installation Directory>/confluence/WEB-INF/classes/com/atlassian/confluence/setup/, the restore fails with these errors:

  • Could not determine the space key from contents of exportDescriptor.properties

  • Restore denied. You can only restore space backups exported from the same major version (e.g. 2.2.x or 2.3.x).

Cause

Lack of Space Key, and wrong Build Number in the exportDescriptor.properties of the demo-site.zip

Resolution

  1. Identify the build number for the version of Confluence (Build number can be found in Confluence Admin >> System Information >> Confluence Information)

  2. Navigate to <Confluence Installation Directory>/confluence/WEB-INF/classes/com/atlassian/confluence/setup/ , and open up demo-site.zip with WinRAR

  3. Modify the exportDescriptor.properties, and change it to this:

    1 2 3 4 exportType=space buildNumber=3390 backupAttachments=true spaceKey=ds

    For this example, we are using Confluence 4.3.1, which has the buildNumber of 3390. Modify this accordingly

  4. Save the file, then refresh the archive

  5. Navigate to Confluence Admin >> Backup Restore, and upload this modified demo-site.zip

Updated on April 8, 2025

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