Unable to Receive Email Notifications From Confluence
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
Email updates are not sent from Confluence
Diagnosis
No error message is logged in Confluence
In addition, test send email failed to your company domain. However test send email works to other domains, eg. gmail, hotmail, other than your company domain.
Cause
Some mail servers may be configured to attempt verification of the sender address before accepting. Mail logs look like:
1
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Jan 26 20:16:46 8291bef994055f31ab2945185c533548 postfix/smtp[23126]: E1CD7A62AA: to=<yourUserName@yourCorporateDomain.com>, relay=mail.yourCorporateDomain.com[<IP Address>]:25, delay=7966, delays=7964/0.01/0.73/0.96, dsn=4.1.7, status=deferred (host mail.yourCorporateDomain.com[<IP address>] said: 450 4.1.7 <yourUserName@yourCorporateDomain.com>: Sender address rejected: unverified address: connect to yourCorporateDomain [<IP Address>]: Connection timed out (in reply to RCPT TO command))
Solution
Resolution
Whitelist the email address used by Confluence so that it trusts messages from that address rather than attempting to verify its validity.
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