Unable to proceed after uploading display picture

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Unable to proceed, after hitting Save (after uploading a profile photo):

(Auto-migrated image: description temporarily unavailable)

Cause

Proxy configuration such as NGINX or Apache that may have prevented the PUT request from being fired

Resolution

Please note that proxy configuration are beyond the support scope of Atlassian Support

Try to bypass the proxy and see whether the problem persists (access via the Confluence IP address and port, example: http://192.168.1.1:8090 ). If the issue is resolved after bypassing the proxy, but you wish to keep Confluence behind the proxy, then try to check the proxy configuration for lines such as this (this is in NGINX):

1 2 if ($request_method !~ ^(GET|HEAD|POST)$ ) { return 444;

You may need to modify it to:

1 2 if ($request_method !~ ^(GET|HEAD|POST|PUT)$ ) { return 444;
Updated on April 8, 2025

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