Unable to Log in Due to Deactivated Users
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
A user that has been deactivated in the past cannot be brought back to life. Even if assigned to the right groups with confluence access.
Note that this applies only to the older mechanism for user deactivation. In newer versions of Confluence, users are removed by removing them from groups with can-use permission, as described in Removing or Deactivating a User.
Cause
In older versions of Confluence, users were 'deactivated'. This action inserted a row into table os_propertyentry with entity_id = theUserId
AND entity_key=confluence.user.deactivated
. This entry is still evaluated but there is no mechanism in newer version to remove this from the database.
Resolution
Backup Confluence
Stop Confluence
Find the user id (=theUserId) of the particular user in table users
Run the following SQL query to identify the row that contains the 'deactivated' information. The entity_name column should have an entry like 'LOC_username':
1
select * from OS_PROPERTYENTRY WHERE entity_id = theUserId AND entity_key="confluence.user.deactivated";
Delete this row from the table
Restart Confluence.
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