Unable to Install Service on Windows Vista

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Unable to start the Confluence Windows Service. The jakarta-service.log file contains:

1 2 3 [2008-03-04 20:41:59] [80 service.c] [error] Access is denied. [2008-03-04 20:41:59] [524 prunsrv.c] [error] Unable to open the Service Manager [2008-03-04 20:41:59] [info] Procrun finished.

Cause

This usually happens for the Microsoft Vista OS running Tomcat. The user account control is enabled causing the service to malfunction.

Resolution

Modifying the system configuration to disable the user access control will allow the service to run. For more information, please refer to this forum.

Updated on April 8, 2025

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