Unable to install plugins using MS SQL due to transaction log exceptions

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When attempting to install Confluence plugins while using MS SQL you may receive this error in atlassian-confluence.log:

1 Caused by: java.sql.SQLException: The transaction log for database 'confluence' is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases

Cause

The transaction log is set at a specific size and is unable to expand as needed.

Resolution

Setting the transaction log to have an auto-growth option instead of 'NONE' should resolve the issue. You may also need to set a larger initial size.  Please see this support article from Microsoft for more information on tweaking this setting.

Updated on April 8, 2025

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