Unable to Import Templates when Multiple Template Bundles are Available

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

If multiple template bundles are available to import, only the templates in the first template bundle on the 'Import Templates' page can be imported. Clicking the 'Import' button for the other template bundles does not do anything.

This issue affects all Confluence 3.2 installations.

Cause

The version of the Atlassian Templates Import Framework bundled with 3.2 has an issue that results in the symptoms described above.

Workaround

Upgrade the Atlassian Templates Import Framework plugin to the latest version:

  1. Log into the Confluence 3.2 administration console.

  2. Navigate to the Plugin Repository.

  3. Locate the Atlassian Templates Import Framework plugin and click the 'Upgrade' link.

If you cannot upgrade the Atlassian Templates Import Framework plugin, you can work around this issue by enabling each of your template bundles individually:

  1. Log into the Confluence 3.2 administration console.

  2. Navigate to your installed plugins.

  3. Disable all template bundles except for one.

  4. Navigate to Import Templates. Import the templates from the enabled template bundle.

  5. Repeat step 3-4 for all your template bundles.

Resolution

Upgrade to 3.3 or later. This issue is being tracked as CONF-19121.

Updated on April 8, 2025

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