Unable to Find Server ID for Confluence 2.5.4 or Before
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The upgrade process requires that a Server ID be entered from my.atlassian.com. There is no Server ID present from Administration > License Details
in Confluence.
Cause
Server IDs were not implemented until version 2.5.5.
Resolution
Please contact our sales team to request a server ID.
ℹ️ Note that for evaluation licenses, the Server ID is required. You can get this from the License Details screen or the Setup Wizard.
Was this helpful?