Unable to Exit Plugin Support Mode due to IllegalStateException

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When trying to come out of plugin safe mode, the following error is thrown:

1 2 3 4 5 6 Error after entering SUpport Mode and later exiting support mode which isn't working java.lang.IllegalStateException: Can not overwrite an existing bean definition: wrappedCacheManager at com.atlassian.confluence.plugin.descriptor.ComponentModuleDescriptor.enabled(ComponentModuleDescriptor.java:72) at com.atlassian.plugin.DefaultPluginManager.notifyModuleEnabled(DefaultPluginManager.java:939) at com.atlassian.confluence.plugin.ConfluencePluginManager.notifyModuleEnabled(ConfluencePluginManager.java:117)

Cause

There is a conflict in the plugin cache.

Resolution

Restart Confluence, then retry disabling plugin support mode.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.