Unable to edit profile with the message "You cannot edit the Full Name or Email fields as you are not using Confluence to manage users"

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

While trying to edit details by going to user profile > edit, the user information fields are not editable and there's a message:

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1 "You cannot edit the Full Name or Email fields as you are not using Confluence to manage users"

Cause

External User Management is enabled and therefore Internal User Management has been disabled.

From this page: Disabling the Built-In User Management

By selecting the 'External user management' option in Confluence, you can disable the group and user management screens in Confluence

Resolution

Go to Confluence Admin > Security and make sure that External User Management is unchecked:

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Updated on April 11, 2025

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