Unable to edit Confluence Cloud pages due to a "This page has failed to load" message
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Upon trying to edit a page, the "publish" button gets greyed out and the following error message is displayed:
This page has failed to load
Retrying in ...
Diagnosis
Check if other pages using the current/new editor can be edited properly.
On the browser's console (via right-click → Inspect → Network tab), a 403 related to the Synchrony service (using the "wikidocs" URL) should be displayed:
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Request URL: https://wikidocs.services.atlassian.com/activationid-services/<ID>/synchrony/v1/data/<ID>/confluence-adf-<PAGEID>?optimistic=true&rewrite-request=trueHTTP Request method: POST ... 403 Forbidden HTTP/1.1 Chrome error net::ERR_FAILED
Confirm that the page(s) can be published by using a personal environment (network and machine).
Cause
This generally happens because there are IP ranges and domains from Atlassian being blocked on the environment used, causing the microservice responsible for drafts and collaborative editing to not load. Some scenarios where this can happen:
Security softwares might not have the Atlassian domains and ranges allowlisted.
The company's network has rules that do not allow the Atlassian ranges and domains to be used.
There might have browser extensions blocking it to be used.
Solution
Make sure to allowlist the IP ranges and domains from Atlassian Cloud. For this specific scenario, *.atlassian.com should help as it would include the wikidocs.atlassian.com URL, responsible for the microservice in question.
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