Unable to Download Attachments in IE over SSL

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

You have enabled SSL for the whole site, are accessing Confluence using Internet Explorer, and are unable to download attachments.

Workaround

Note that if you try to open an attachment in a secure site, for example a PDF document, the relevant application will try to open it but will report the file cannot be found. However, if you right click the document and choose "Save as" this will work. To fix this, in IE go to the "Tools>Internet Options" menu and click on the Advanced Tab, scroll down to the bottom and look for "Do not save encrypted pages to disk" option - make sure that you un-tick this. This problem is known to affect IE6 and has been reported in Microsoft's knowledge base.

Cause

IE will not download attachments into its Temporary Internet Files folder when in SSL mode. You can find further information in these links:

Resolution

Place these Valve elements in the Context element of conf/server.xml:

<Valve className="org.apache.catalina.authenticator.FormAuthenticator" securePagesWithPragma="false" /> <Valve className="org.apache.catalina.authenticator.NonLoginAuthenticator" securePagesWithPragma="false" />

ℹ️ See CONFSERVER-16168 - File downloads over SSL don't work with cache control in IE browser.

Updated on May 22, 2025

Still need help?

The Atlassian Community is here for you.