Unable to configure Application Link from Confluence to JIRA

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Application link from Confluence to JIRA does not show options to configure authentication

The following appears in the Application Link configuration screen:

(Auto-migrated image: description temporarily unavailable)

Cause

The admin configuring the Application Link does not have administrator access on both Confluence and JIRA.

Resolution

  1. Create a new admin user in JIRA

  2. Delete the old application link

  3. Create new application link and tick on "I am an administrator on both instances."

  4. Complete configuration of the application link

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.