Unable to Add User Due to 'Cannot write to read-only GroupManager'
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When adding a user, or perhaps adding a user to a group, an error is thrown.
Diagnosis
When modifying a group, this stack trace is generated:
java.lang.UnsupportedOperationException: Cannot write to read-only GroupManager [ldapRepository]
at com.atlassian.user.impl.ReadOnlyGroupManager.addMembership(ReadOnlyGroupManager.java:35)
Stack Trace:[hide]
java.lang.UnsupportedOperationException: Cannot write to read-only GroupManager [ldapRepository]
at com.atlassian.user.impl.ReadOnlyGroupManager.addMembership(ReadOnlyGroupManager.java:35)
at com.atlassian.user.impl.cache.CachingGroupManager.addMembership(CachingGroupManager.java:156)
at com.atlassian.user.impl.delegation.DelegatingGroupManager.addMembership(DelegatingGroupManager.java:231)
Cause
There is a group with a duplicate name in the LDAP repository, usually confluence-users or confluence-administrators.
Solution
Make sure these group names, reserved for internal use, are not in your LDAP repository.
Was this helpful?