Unable to Add Attachments to a Page

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Attaching a file to a page in Confluence fails with the following error message:

(Auto-migrated image: description temporarily unavailable)

As well as an error similar to the following the atlassian-confluence.log file.

1 2 3 2012-06-14 17:06:05,261 ERROR [http-1424-1] [confluence.plugins.dragdrop.UploadAction] execute Failed to save file. -- url: /plugins/drag-and-drop/upload.action | userName: admin | referer: http://example:8090/pages/editpage.action?pageId=1703940 | action: upload java.lang.RuntimeException: Error creating temp file in folder: /example/attachments/ver003/205/236/1736705/190/203/1703940/1933317

Causes

  1. This occurs when the operating system user running Confluence has inadequate write permissions to the Confluence home directory/attachments

  2. There is not enough disk space available for the attachment to be written

Resolution

  1. Ensure that the operating system user running Confluence has full read/write permissions to the Confluence home directory

  2. Ensure that there is space available on the hard drive housing Confluence's home directory and that there are no space quotas set on the Confluence home directory/attachments folder preventing it from being written to

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.