Unable to access the PII Manager, PII Access Log, PII Action Log menu in personal space
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When using 3rd party plugin, PII Protector in Confluence, a user who is not an admin user is not able to access PII menu items in their personal space however they can access these menu items in a general space.
Normally after installing PII Protector, users can see menu items of "PII Manager", "PII Access Log", "PII Action Log" in "Space tools" > "Content tools" menu and can manage/see logs related with this plugin.
However the problem is that a specific user (who is not an admin user) is unable to access these menu items even though they have all permissions of their personal space. The same user can access these menu items if they have all permissions for a general space. The issue is faced only while accessing these menu items in personal space.
On accessing the menu items, user sees "ERR_TOO_MANY_REDIRECTS" error in the browser.
Diagnosis
On testing it is found that the issue is faced only in a specific case when the user has a dot (.) in their username, for ex : john.smith
In such case only the issue is faced in a user's personal spaces.
The issue is not faced for users that do not contain a dot (.) in their username (like : johnsmith)
As personal spaces use user's username as the space key, so it can be identified from the space key (ex: ~john.smith) and see if they are affected by this issue or not.
Cause
As checked with plugin vendor Enhancera support team, the issue was due to a bug in the plugin's source code.
Solution
To fix the issue, please upgrade the 'PII Protector' plugin to v2.2.2 or above which includes the fix for this specific issue.
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