Unable to access the Confluence Administration screens after Banner update
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After the Confluence site banner update, users are unable to access the Confluence Administration screens, such as General Configuration, User Management, and Manage Apps etc as they encounter a blank screen while attempting to access these pages.
Environment
Confluence Data Center 8.5.14
Diagnosis
While reviewing the HAR logs for accessing the Confluence Administration screen, it's observed that the response for the request https://Confluence_Base_URL/authenticate.action?destination=%2Fadmin%2Fviewgeneralconfig.action
included the site banner's custom HTML, which was not correctly formatted.
Custom HTML for Banner
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<!-- div style=" font-weight: bold; text-align: center; background: yellow" >
Scheduled DataCenter Shutdown Event on ****. Services will be unavailable from *****. Please be aware of upcoming maintenance.
</div>
Solution
Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
Since the Confluence Administration > Custom HTML screen was inaccessible, you can verify whether the Custom HTML for the banner is incorrectly formatted.
To check if the Custom HTML for the banner is incorrectly formatted, you can run the following SQL query:
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select bandanavalue from BANDANA where BANDANAKEY='atlassian.confluence.settings';
The output of the above SQL statement reveals the banner details within the
<customHtmlSettings>
tag, specifically inside the<beforeHeadEnd>
section.This contains an erroneous comment
!--
for the<div>
tag.
Incorrect Custom HTML
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<customHtmlSettings>
<beforeHeadEnd>
<!-- div style=" font-weight: bold; text-align: center; background: yellow" >
Scheduled DataCenter Shutdown Event on ****. Services will be unavailable from *****. Please be aware of upcoming maintenance.
</div>
.
.
</beforeHeadEnd>
<afterBodyStart>...</afterBodyStart>
<beforeBodyEnd>...</beforeBodyEnd>
</customHtmlSettings>
Once confirmed, the incorrect value (comment inside the
<div>
tag) for the custom HTML in the site banner can be updated in the database (BANDANA table) either manually or by contacting the DBA, with the following corrected values in the output from the SQL query above.Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
Correct Custom HTML
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<customHtmlSettings>
<beforeHeadEnd>
<div style=" font-weight: bold; text-align: center; background: yellow" >
Scheduled DataCenter Shutdown Event on ****. Services will be unavailable from *****. Please be aware of upcoming maintenance.
</div>
.
.
</beforeHeadEnd>
<afterBodyStart>...</afterBodyStart>
<beforeBodyEnd>...</beforeBodyEnd>
</customHtmlSettings>
After the updating the value in the DB table, please restart your Confluence nodes for the changes to take effect.
In case of further assistance please reach out to the Atlassian Support team and share the information that's been gathered so far along with a fresh Support zip file.
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