Unable to Access Backup Administration Page Due to Invalid Escape Character
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The following appears in the atlassian-confluence.log
:
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2012-11-15 19:01:47,722 ERROR [http-8090-2] [[Standalone].[localhost].[/].[action]] log
Servlet.service() for servlet action threw exception
java.lang.Error: Invalid escape character at line 1 column 5.
at ognl.JavaCharStream.readChar(JavaCharStream.java:320)
at ognl.OgnlParserTokenManager.getNextToken(OgnlParserTokenManager.java:1536)
....
Cause
The Backup Path for custom backup contains invalid escape character(s)
Resolution
To fix this, we need to edit the backup path manually in the database:
Backup your database
Run the following SQL query which outputs the
BANDANAVALUE
all of Confluence settings configured:1
SELECT BANDANAVALUE FROM BANDANA WHERE BANDANAKEY='atlassian.confluence.settings';
Copy the output of
BANDANAVALUE
and paste it into NotepadLocate for
<backupPath>
XML tag. The path is located inside this tagIf there are any invalid characters, edit the backup path. Use forward slashes "/" instead.
To update the backup path, run the following query. Please edit
<insert-bandana-value>
in the query below from the editedBANDANAVALUE
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UPDATE BANDANA SET BANDANAVALUE='<insert-bandana-value>' WHERE BANDANAKEY='atlassian.confluence.settings';
Go to Confluence Admin > Cache Statistics > Flush All
If issue persists after performing the steps above, try to restart Confluence
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