Tools Menu Not Available In Any Page

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

  • You can see and click on "Tools" in Confluence page but the menu/options are missing.

  • Enabling Plugin Safe Mode didn't make any difference

  • The problem persists even if you are using the default theme with no existing customization e.g. layout, stylesheet

Diagnosis

Run the following query to check if confluence.content.action.menu is set to false in the database:

1 select * from BANDANA where BANDANAKEY='plugin.manager.state.Map';

If the result is returned with something like below, proceed to the resolution section:

1 2 3 4 5 6 7 8 9 10 ... ... <map> <entry> <string>confluence.content.action.menu</string> <boolean>false</boolean> </entry> </map> ... ...

Cause

confluence.content.action.menu (Content Action Menu Sections Add On) which is a system/bundled plugin is set to false in the database

Solution

Resolution

Update the database (BANDANA table) and set confluence.content.action.menu to true and restart Confluence:

1 2 3 4 5 6 update BANDANA set BANDANAVALUE='<entry> <string>confluence.content.action.menu</string> <boolean>false</boolean> </entry> </map>'  where BANDANAKEY='plugin.manager.state.Map';

Backup the database before performing any changes to it as a precaution measure

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.