Tomcat Fails to Start

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Tomcat fails to start with the following error: "The system could not find the environment option that was entered."

Symptoms

The following appears in Tomcat logs (commons-daemon*.log):

1 2 3 4 5 [2012-11-23 11:48:25] [info] Commons Daemon procrun (1.0.5.0 32-bit) started [2012-11-23 11:48:25] [info] Running 'Confluence' Service... [2012-11-23 11:48:25] [info] Starting service... [2012-11-23 11:48:25] [error] CreateJavaVM Failed [2012-11-23 11:48:25] [error] The system could not find the environment option that was entered.

Diagnosis

The error most probably occurs upon startup in a Windows environment with Tomcat application server, after modifying JAVA_OPTS (system properties).

Cause

In most cases, the root cause is having a Java System Property that is not recognized by Tomcat.

Solution

Resolution

  • Please review the Recognized System Properties page for more information about accepted properties, and fix your startup configuration accordingly.

  • The issue can happen when you try to specify the -server property when the <JAVA-HOME>/jre/bin/server/jvm.dll is being used as the JVM. Technically these two settings are redundant, thus the -server parameter is rejected and startup fails.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.