The table plugindata is full

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When try to update plugins, you will see the following in the atlassian-confluence.log

1 ERROR [pool-19-thread-1] [sf.hibernate.util.JDBCExceptionReporter] logExceptions The table 'PLUGINDATA' is full

Cause

This is due to corrupted plugin cache causing the issue to occur.

Resolution

Clear the plugin cache .This issue can be caused by table size restriction in this case please refer to the knowledge based article Cannot upgrade due to full table in MySQL.

Updated on April 8, 2025

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